本文使用Windows 2008 R2 进行测试,同时使用GNS3来进行网络模拟。
网络拓扑如下:
Window VPN 组网网络拓扑
注:GNS3可以使用cloud来桥接网卡,所有可以将eth2理解为桥接到了BJ-R的主机上,而eth3桥接到了HZ-R的主机上。
GNS网络拓扑如下:

路由器配置

R1路由器配置:

# 端口配置
R1#configure terminal
R1(config)#interface FastEthernet 0/0
R1(config-if)#ip address 11.1.1.2 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#interface FastEthernet0/1
R1(config-if)#ip address 11.1.2.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
# 路由配置,添加静态路由
R1(config)#ip route 11.1.3.0 255.255.255.252 11.1.2.2

R2路由器配置

R2#configure terminal
R2(config)#interface FastEthernet 0/0
R2(config-if)#ip address 11.1.3.1 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#interface FastEthernet0/1
R2(config-if)#ip address 11.1.2.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
# 路由配置
R2(config)#ip route 11.1.1.0 255.255.255.252 11.1.2.1

Windows配置

  1. 安装路由和远程访问


  1. 启用路由和远程访问


选择自定义配置

勾选,启用所有服务

之后,点击下一步、完成即可启用路由和远程访问功能。

  1. 配置NAT功能


添加本地连接网卡。(注:本地连接为外网IP地址,本地连接2为内网IP地址)

注意:需要在外网网卡启用NAT功能。

同样的步骤,启用本地连接2的网络地址转换功能,指定本地连接2为专用接口。

网络连通性测试(在BJ-PC上测试):

  1. 添加请求拨号


设置VPN名称

设置VPN类型

设置IP地址,注意,这里需要设置的为对端的IP地址(也就是HZ-R的IP地址)

勾选在此接口上路由选择IP数据包添加一个用户账户使远程路由器可以拨入选项

添加一条静态路由

添加杭州分布的网段地址,搭建完成后,所有指向192.168.1.0/24网段的流量都将走VPN过。

设置VPN-BJ的密码

设置拨号到HZ-R的VPN(这里需要填入的是HZ-R上创建的账户信息)

这里还需要指定VPN的IP地址,否则网络无法通讯。



添加指定10.1.4.0/30的网络流量走VPN过。


最后连接VPN,注意:两边都需要连接

注:以上步骤HZ-R也需要使用同样的步骤再配置一遍,
测试网络连通性:

本文经「原本」原创认证,作者乾坤盘,访问yuanben.io查询【60D67ET2】获取授权信息。

最后修改:2020 年 12 月 18 日 10 : 16 PM
如果觉得我的文章对你有用,请随意赞赏